What to Do If WhatsDrop Is Dropping Support for Your iPhone

What to Do If WhatsDrop Is Dropping Support for Your iPhone
Photo: BigTunaOnline, Shutterstock

WhatsApp is the most popular chat app in the world, hosting over two billion active users. A lot of us rely on the app’s fun and unique features to communicate with friends and family across the globe, so it’s imperative the service continue to work on our iPhones. Unfortunately, WhatsApp is preparing to stop support for certain versions of iOS, and, by effect, certain iPhone models as well. Is yours one of them?

Let’s start with the good news: If your iPhone is still receiving software updates, you have nothing to worry about. In fact, some iPhones that Apple doesn’t support with updates will still be able to run WhatsApp without issue. However, that will still leave some users in the lurch. Let’s take a look at who this drop in support affects.

What iPhones will WhatsApp stop supporting?

WhatsApp is dropping support for iOS 10 and iOS 11, which Apple released to the public in 2016 and 2017, respectively. While it’s never fun to lose support, software — especially mobile software — is often abandoned like this after a certain point. Apple supports its own iPhones for up to seven years; any support from specific apps thereafter is just a bonus, especially when the operating system is as old as iOS 10.

Luckily, this drop in support isn’t immediate. WhatsApp is giving users time to react, only pulling the plug on Oct. 24 of this year. As WABetaInfo reports, some users have already seen a notification urging them to update their iPhones by this fall date, or else lose access to WhatsApp on that particular device.

How to keep using WhatsApp on your older iPhone

So, what does this mean for you? If your iPhone — or the iPhone of someone you know — is running iOS 10 or iOS 11, it won’t be WhatsApp-ready come Oct. 24. If your iPhone is compatible with at least iOS 12, you should update as soon as possible, or, at least, before October. For example, if you’re using an iPhone 5S or iPhone 6 but running iOS 11, you should update to the latest version of iOS 12. These iPhones won’t be able to run Apple’s iOS 15 and all the features it comes with, but you’ll still be able to use WhatsApp.

What to do if your iPhone can’t update to at least iOS 12

However, if you have an iPhone 5 or iPhone 5c, which can’t be updated past iOS 11, you won’t be able to use WhatsApp on your device once Meta drops support. Unfortunately, the only solution here is to upgrade your iPhone to something that runs at least iOS 12, although it’s only a matter of time before that version of iOS is no longer supported, either.

Our advice is to upgrade your iPhone to something that is currently supported by Apple. You don’t need to buy a $1,699 iPhone, either: Apple’s current iPhone SE starts at $719, and comes with many modern features you’d expect from a more expensive iPhone. These iPhones, and others like them, will be supported by apps like WhatsApp for years to come. Take a look around to find the mobile WhatsApp machine that works best for you.

Log in to comment on this story!