A critical vulnerability has been discovered that lets attackers gain root access through compromised MySQL-based database systems. It affects MySQL, MariaDB and PerconaDB which are all immensely popular with organisations big and small. Here's what you need to know about this privilege escalation bug.