How Do I Troubleshoot Slow Speeds From My New ISP?

How Do I Troubleshoot Slow Speeds From My New ISP?

A friend of mine recently asked if their plan to move from DSL to a cable internet provider was a good one. As one who made that same leap many years ago, I felt like shipping them a celebration beer. For me, the transition was a joy akin to what I’d imagine the Mandalorian feels after getting the hyperdrive to work after several days of cruising at sublight speeds.

But what happens if your new ISP’s “speedier” plan isn’t very fast at all? That’s the predicament that Lifehacker reader Gilbert is dealing with, and he recently wrote to Lifehacker with the following question:

“Today I changed from RCN to Spectrum Internet. On Speedtest.net with RCN service, I always got fast speeds, usually about 150 to 225 Mbps.

When I switched over to Spectrum, with the same computer but different router and modem, now I was only getting about 30 to 60 Mbps on Speedtest.net. The tech person from Spectrum showed me on his device that the incoming speed was over 300 Mbps, sometimes over 400 Mbps. He tried giving me a new router and modem, but the result was the same.

I tried several different speed test sites, with a range of about 30 to 70 Mbps. The Spectrum tech seemed convinced he had done his job, and that Spectrum was providing the promised speeds. He couldn’t explain why the RCN results were so much better. (Before he started, I showed him a speed test result for RCN, which was over 200.)

I read about being “throttled” and downloaded a free VPN from Hotspot Shield, but that seemed to make no difference.”

When your new ISP is only fast for the tech that tests it

This is a fun one, Gilbert. You’ve taken some of the wind out of my advice-giving sails by trying a few troubleshooting tricks I would have suggested, which is great! I’m sorry they haven’t fixed your problem, but at least you can find solace in the fact that you did the absolute right things: You tested your speeds to confirm there’s an issue, you contacted your ISP, you had them send out a tech to test your speeds themselves, and you even replaced potentially problematic equipment.

Since the problem persists and someone else was able to get faster speeds on your network than you, we can narrow our collective troubleshooting efforts a bit more. My gut feeling is that something might be up with your home network that’s causing your device to show slow speeds and another person’s device to show fast speeds.

Try testing using as many devices as you can

You didn’t specify what you’re connecting to your router to run your various speed tests, nor what the Spectrum tech used to run their speed tests. You should first try to connect a similar device in a similar way the Spectrum tech did for their tests. For example, if they whipped out their somewhat-new iPhone, connected it to your router’s wireless network, and got great speeds, you should take out your somewhat-new smartphone (if applicable), connect it to the same wireless network, and run some similar speed tests.

I would try assaulting your poor router with as many devices and speed tests as you can. Connect up whatever devices you have available via Ethernet — using different cables and ports on your Spectrum router/modem — and run speed tests on them. Connect different devices to your wireless network (or networks, if you have more than one running), and run speed tests on them.

Basically, the goal is to see if there’s any combination of connections that will get you the same speeds the Spectrum tech experienced. I suspect there is, because it wouldn’t make sense that only one person, on only one device, would get fast speeds while others — namely you — cannot. That’s especially true if you haven’t messed with any settings on your router or modem (or combined device) since the Spectrum tech took a look. These great speeds are there; you just have to unearth them.

Is it a hardware issue? A connection mismatch?

The curious part of this puzzle is that I’d normally suggest that the devices you’re using for your speed tests might be responsible for your slow results. For example, if your router/modem supports a speedy wireless-ac connection but you’re testing it using an older wireless-n device, you’re probably not going to get as good of results as someone connecting to it with a newer wireless-ac device.

However, you already had fast speeds from your old Internet provider. Assuming you’re using the exact same devices, it’s a bit of a head-scratcher why you’d suddenly see slower speeds on Spectrum (and its hardware) — especially, again, when someone else can get faster speeds on their tests.

In instances like, these, my troubleshooting turns to tinkering:

  • Make sure any wired devices you’re connecting as part of your tests support gigabit Ethernet.
  • Make sure you’re using Cat6 Ethernet cables between your devices and your router, as well as your router and your cable modem (if applicable)
  • Try a different Ethernet cable for the connection if wired devices (that support Gigabit Ethernet) are reporting slow speeds
  • Make sure the wireless devices you’re using for your testing support wireless-ac
  • Even if they don’t, make sure any wireless device you’re connecting to your router for the purposes of testing is connecting to a wireless network on the router’s 5GHz band.
  • Make sure you’re standing near your router, within line-of-sight, when you’re conducting your speed tests
  • If possible (and only if you can do it safely, pandemic-wise) borrow a friend’s laptop with Gigabit Ethernet connections and/or a smartphone or tablet with wireless-ac to help conduct additional tests

It’s possible, though improbable, that there’s a problem with one of your devices or your wireless network that’s slowing things down. You can try addressing this any number of ways: switch Ethernet cables (to a different Cat6 cable); buy a high-quality gigabit ethernet adaptor or wireless-ac dongle for your desktop or laptop; make sure your router is splitting your Wi-Fi networks, and always connect to 5GHz when you’re near it to run your speed tests; and make sure your router/modem is running the latest firmware.

Finally, assuming that you have a combined router/modem from Spectrum and not separate devices, you can try setting up your router/modem as a bridge — basically, a cable modem without any router functionality whatsoever. Then, buy an inexpensive (but solid) third-party router, like TP-Link’s Archer A7, and connect it to your router/modem to use as your primary router, which could give you the speed boost you’re seeking.

If I had to stick with one answer, though, I think there’s some kind of misconfiguration going on with your connection that’s inhibiting your speeds. That could be something as simple as your router assigning your device to a slower 2.4GHz network instead of a faster 5GHz network, assuming that it’s handling this provisioning itself (and just giving you a single SSID that you connect to). You’ll never see 400Mbps on a wireless-n connection, so that might be the problem right there — which you can solve by going into your router’s settings and splitting your Wi-Fi networks into separate SSIDs for 2.4GHz and 5GHz, as mentioned.

Let me know if any of these suggestions work! I’m curious to see what, if anything, takes care of your problem.

Do you have a tech question keeping you up at night? Tired of troubleshooting your Windows or Mac? Looking for advice on apps, browser extensions, or utilities to accomplish a particular task? Let us know! Tell us in the comments below or email [email protected].

Log in to comment on this story!